Enrive[ a / b / biz / c / co / g / gg / global / k / lit / Movies / mu / nsa / pc / pol / sci / toon / tv / x / ]

Random - /b/ [Catalog] [Board FAQ]




CAPTCHA Image

TopBottom

Image Thumbnail
Thread was moved to Off Topic

Since Gadmin just locked the global thread, I've run into a few bugs, so this has to be the inofficial global thread until a new global thread is made. First of all, my old admin account hasn't been cleared for posting, forcing me to now have TWO admin accounts - the /pain/ admin account, and the /doom/ admin account. Second of all, you can't add FAQs to boards anymore. When you click on the link to edit, you are instead taken to the login page, and logging in just leads to a page saying that you're already logged in.


>>

>>232936 >my old admin account hasn't been cleared for posting, What do you mean by that? That you are banned from posting? I've managed to edit a faq right now, but I did get a login problem earlier today as well - after logging in I was taken again to the login page. Which is odd, because there were no changes to the code regarding that. Are you still unable to login/edit faqs?

>>
Image Thumbnail

>>232936 With your pain admin account, try replying to a thread on /newchums/ and fill out the captcha, don't try to upload a pic.

>>

/greta/ admin here. I just edited the faq. Are you trying to edit the faq while logged in as board admin, and clicking on the account button at the top of the page? Then click on the edit button next to the board name?

>>

First of all, I don't think I've made any posts with my admin account. I don't know. Can you link me to the post count page? I can't find the link to it. I've posted in newchums, as you can see. Needed to fill in a captcha for it. Apparently newchums can create boards? Is that the error here? (Please don't disown me from my boards, by the way.) Second of all, the FAQ login issue, might be a case sensitive issue. See, I've have been posting from lowercase accounts for a few days, but the owner is listed as partially uppercase, because that's the proper username. For example, "Greta" might be an owner of a board, but I'm logged in as "greta" in the posting window "Post with: greta". Also, I said something wrong before: I own both boards with my admin account, so I'm glad that that's not a problem. Sorry for the delay in replying - had to post other shit.

>>

I logged out both accounts and logged back in with properly case sensitive names, and now I was able to edit the FAQ without getting the login page, so it's confirmed: It's a case sensitive issue, whether you should be able to log in with lowercase in the first place or not. I still can't post in the regular boards with the properly cased admin account, but I guess I just have to be a newchum for a while - no biggie.

>>

Hold on here: So if there is no user called "gadmin" in lowercase, would I be able to create one, then click on "Account", and see a list of how many boards that you directly own, including secret boards? That's like the mother of exploits.

>>

...or "gaDmin" or "gAdMin". I'm not going to try to hack you, but you better fix this ASAP.

>>
Image Thumbnail

>>232939 So, it just turns out you're retarded. By any chance can you reproduce the bug?

>>
Image Thumbnail

Board admin accounts aren't case sensitive. Neither are Anon Id's I just logged in with a mix of upper and lower case letters to make this post, when usually it's all lower case.

>>
Image Thumbnail

>>232936 I justed tried to edit my board faq after logging out, and loging in as 2 different board admins. I used mixed upper and lower case to login, instead of the way I usually do. First I logged in as the admin for the board I wanted to edit, then logged in as board admin for another board. When I clicked on the board I wanted to edit, it brought me back to the login screen. I logged in with the same name I did the first time, but I typed it correctly in all lower case. Only then was I able to edit the board faq, congrats chum, you found a bug. Board admin accounts are case sensitive. Anon ID accounts aren't, but are associated with board admin accounts none the less. I do t think this is a security issue tho, you would still need to know the correct password none the less.

>>

>Anon ID accounts aren't, but are associated with board admin accounts none the less. >I do t think this is a security issue tho, you would still need to know the correct password none the less. According to my theory, not if I make one up for my own account. If I can make an account called "gAdMiN" and make the password "helga", then, when I access my own account, all non-case-sensitive accounts should be listed, including those for "Gadmin". ...but maybe you're right - who knows? At least confirm that this isn't the case.

>>

>>232942 >>232943 >>232947 When creating an account, case doesn't matter. So if "GaDmin" exists, you can't create "gadmin" >>232941 it seems a case issue exists when checking if someone is logged in or not, and when the case doesnt match it sends you back to the login screen since the system thought your login expired. I will look into it later today and fix it. Thanks everyone for finding this out. Can't watermark/login because using someone else's computer

>>
Media deleted

>>232941 This issue should be fixed

>>

>>232940 Your post count should be listed here: https://enrive.org/home

>>

>>232963 Then I've discovered ANOTHER bug: >You are currently logged in as: > >Qadmin (0 posts / 0 active days) > >Qanon (47236511 posts / 351 active days) Notice how it says 0 posts and 0 active days? I know I've posted AT LEAST one post 1-2 days ago, with my admin account. Those posts aren't counting.

>>

>>232965 if a post was deleted, you lose -1 post count. Try making a post with that account and see if it gets +1. And you only get +1 active day on the second day's post after your first post (something I should probably improve)

>>

"Qadmin (2 posts / 1 active days)" It seems the previous post didn't take, but these two new posts did, and I immediately also went to one active day at the same time - didn't have to wait 24 hours. I wasn't aware that any of my posts were deleted, but the old post I did yesterday, is still there, and I doubt more posts can get deleted than what you post, so I doubt that you can get negative posts, so there's definitely something going on here, with the site not recognizing some posts.

>>
Media deleted

>>232970 thanks, I'll double check this

>>

Discovered another bug - I can't delete this post: https://enrive.org/b/thread/232954#232973 Normally it works because I delete the post with the typo BEFORE I post the next post, but right now I posted the corrected post BEFORE I tried deleted the old one. ...but it doesn't work, because I get told that it's not my post. This coincides with me also having my admin account as the default account (listed as the highest in the dropdown list), if that matters. I posted with my non-admin account, so maybe when it comes to deleting a post, I can only do that through the default account. With all due respect: Every time I encounter a new bug, I remember you talking about how neat and under control everything is in OOP. It sure doesn't seem "encapsulated" to me.

>>
Image Thumbnail

>>232975 Did you select the right account for that post you tried to delete in the drop down menu?

>>

>>232978 Ooh... I'm dumb. I selected the "Post with: " drop down menu up top. There's no bug. I didn't even see that drop-down there. Why am I so blind that you have to point out every single element on this site, before I notice them?

>>
Image Thumbnail

>>232979 You brainlet

>>

>>232981 I know. This is really embarrassing.

>>

>>232979 >I didn't even see that drop-down there. The CSS/interface is kinda messy because I'm awful at CSS. Everything we see was created by a guy that helped me out some years ago. Interface definitely needs improvements everywhere so ti is more logical

>>

I read this article and thought of you, Gadmin, since it covers opsec and how to keep sites anonymous: https://arstechnica.com/tech-policy/2019/10/child-porn-purveyor-learns-the-hard-way-that-bitcoin-is-traceable/

>>

Ah! Gadmin, I know what I probably did. There's probably no bug regarding posts that don't count. What I probably did was forget to type in the captcha, and on the (new) error page I then forgot to change the drop-down to my admin account AGAIN, so I probably typed in the captcha and posted with my non-admin account instead.

>>
Image Thumbnail

>>233040 >I rode the short bus it shows

>>

>>233042 I did make an entire thread about how I'm retarded. What more do you want from me?

>>
Media deleted

>>233040 I've made a note to double check that regardless. I might change the way I code it. In the old system, your last username/password would be stored, and now it is stored by login order. Not sure which one is superior. By login order is perhaps less error prone to people, but I should maintain the account that tried to make the post if there were errors during posting, will add a note for that as well

>>

>>233068 Smart. I didn't know that anything could be done about the list order on that page.